Version 0.2c

Basierend auf der Multi Camera IR Control Library Version 1.7 (07.12.2011) von Sebastian Setz habe ich die notwendigen Funktionen zur Infrarotauslösung der Kameras der großen Hersteller eingebaut und die Versionsnummer auf 0.2c erhöht.
Die Bibliothek und weitere Informationen dazu finden sich hier, sie ist für den Betrieb aber nicht erforderlich. Die neuen Funktionen wurden noch nicht getestet, über Rückmeldungen (Kamerahersteller und funktioniert oder funktioniert nicht) wäre ich dankbar, da ich selbst nur mit Canon testen kann.

12 thoughts on “Version 0.2c”

  1. Die neue Software sieht ja wirklich gut aus, schiesst mir aber für mein Projekt deutlich zu weit nach vorne. Ich werde bei der alten bleiben und diese für meine DropletMachine weiter anpassen und optimieren, sozusagen einen Fork von deiner Software machen wenn dir das recht ist.

  2. Aber sicher. Ist ja schließlich open source :) Letztlich sollte sich jeder heraussuchen, was er braucht.
    Es ist aber prinzipiell kein Problem, die neue Version auf die Funktionalität der alten Version zu reduzieren, Du kannst eigentlich alles in den Defaults so einstellen, wie Du es gern hättest (oder es später übers Menü ändern).

    1. Gut, dann muss ich mir die neue Version noch mal in aller Ruhe zu Gemüte führen. Ich habe übrigens noch einen Bug im Zusammenhang mit meiner Nikon. Sie löst beim Single Shot nicht richtig aus, das Bild bleibt schwarz, beim Serien Shot klappt es direkt nach dem ersten Bild (das erste ist schwarz die anderen sind gut) hast du spontan eine Idee woran es liegen könnte, ist es ein Soft oder Hardware Problem?

      1. Wenn das Bild komplett schwarz ist, hat der Blitz nicht rechtzeitig ausgelöst. Kann es sein, dass der Blitz im “Schlafmodus” war, weil längere Zeit nichts passiert ist?

        1. Ne das war es nicht, hätte ich aber auch gleich drauf kommen können. Die Kamera macht auf und geht sofort wieder zu, während es im Serien Modus deutlich länger gehalten wird. Die Kamera steht auf Bulb Modus und wird somit komplett vom Arduino, was die Belichtung angeht, gesteuert.

          1. Hm, da muss ich jetzt mal überlegen, woran das liegen könnte. Hab zugegebenermaßen nie mit Bulb getestet. Mit welcher Software arbeitest Du?

          2. Aktuell die 0.1d, selbst beim 100ten lesen des Quellcodes raff ich einfach nicht warum es in der Schleife nach dem ersten Bild anders läuft als beim einzel Bild…

          3. Verstehe ich eigentlich auch nicht, weil die Schleife wiederholt ja nur die Einzelbildfunktion x mal nacheinander und sorgt für die Pausen dazwischen. Evtl. musst Du die Aktivzeit vom Auslöser verändern, aber das hab ich nicht mehr so genau im Kopf, ist schon eine Weile her, dass ich mich damit beschäftigt habe.

            Probier mal die neue Version, da lässt sich die Aktivzeit für den Auslöser problemlos im Menü einstellen.

  3. Das Problem mit meiner D300 hat sich übrigens geklärt, es liegt an der Belichtungsmessung (trotz vollständig manuellen Modus versucht sie zu messen) hier raus erklärt sich dann auch warum es im Serien Modus mit 5 Sekunden Delay geht und mit 10 Sekunden nicht (hatte die Variablen direkt im Source Code schon umgeschrieben auf für mich sinnvollere Werte). Abhilfe verschafft einem die Belichtungsmessung auf unendlich lange zu stellen und vor dem ersten Foto kurz auf die AF Taste zu drücken. Danach ist das Problem behoben. Eine andere Methode, die allerdings unschön ist, wäre das Brücken des AF Kontakts nach GND um die Kamera ständig Alarmbereit zu halten. Hier hat man dann aber keine Möglichkeit mehr überhaupt was an der Kamera umzuschalten oder zu kontrollieren.

    1. Da hat Nikon ja ein sinnvolles Feature eingebaut :)

      Aber schön, dass es jetzt funktioniert. Du kannst mit den neueren Versionen (0.2 aufwärts) den Autofokus übrigens getrennt steuern, d.h. ggf. deutlich vor dem Auslöser aktivieren. Da passiert auch nichts anderes, als den AF-Kontakt auf GND zu ziehen. Das sollte das Problem eigentlich lösen, oder?

      1. Ich muss mich da noch mal rein fuchsen, hatte die letzten Wochen wenig Zeit um die Maschine (und noch ein paar neben Basteleien) weiter zu machen. Werde mich aber melden. Auf die Lösung bin ich eigentlich auch nur aus einem anderen Grund gekommen, ein Kollege hat einen Gewitter Trigger gebaut, und er hatte das gleiche Problem wie ich. Am Ende hat er es durch brücken des AF gelöst, das finde ich allerdings unschön da ich so nicht mal eine Bildkontrolle machen könnte. Wie gesagt ich schau mir das die Tage noch mal an und Melde mich noch mal.

Leave a Reply

Your email address will not be published. Required fields are marked *